Televisor HELP ME!! Me estoy volviendo tonto!!

Conversación publicada en el foro Multimedia

 
A ver compañeros si me podeis arrojar un poco de luz porque me estoy poniendo de los nervios. Os pongo en situación.

Tengo la play conectada por un cable RGB de euroconector a la TV. Hasta ayer por la noche funcionaba perfectamente. Hoy la he encendido y la calidad habia bajado totalmente, de hecho ni siquiera se me ponia en el canal correcto automáticamente al encenderla como siempre. Conclusión, parece que ha perdido su funcionalidad RGB. Los colores se ven correctos pero con la misma calidad que el cable original de PS3. De hecho he pinchado el cable original y la calidad es calcada.

Mi tele tiene dos entradas RGB por euroconector, así que la solución parece fácil no? Cambio de entrada y... La funcionalidad RGB vuelve 100% pero la imagen se ve en un tono violeta un poco raro...

Tengo otra TV también con entrada RGB por euroconector y cuando la conecto se ve también en ese color lila.

Esta claro que el problema no esta en la TV porque en las dos me falla, aunque es raro que en una entrada de la misma TV se me vea como el cable Amarillo original y en la otra se vea RGB pero con el fondo lila.

¿¿Cual creeis que puede ser el problema??

He reiniciado la PS3 pulsando 5 segundos el botón de encendido hasta que ha pitado, pero no he conseguido nada....

Gracias por adelantado!
--- [ Añadido ] -----
Añado imagen, asi es como se ve... He puesto el menu de la tv para que se note mas el contraste....

IMAGEN
GTA 5 Red Dead Redemption 2 Final Fantasy XV Kingdom Hearts 3 The Last of Us 2 God of War FIFA 17 Final Fantasy VII Remake Horizon: Zero Dawn